电影节
Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic
Problem Description
某届电影节评选电影,共有两部电影进入最后评选环节,有n名观众,每个人有一次投票的机会,每个人都按照规则投给其中一部电影。为了了解情况,记者随机询问了一些人,一共询问了m次,特别神奇的是,记者每次都询问两个人,而且这两个人都把票投给了同一部电影,观众编号为1~n。
Input
多组输入,每组第一行是两个整数n,m (2 <= n <=100000,0 <= m < n/2),接下来m行数据,表示m次询问,每行数据有两个整数a,b代表观众的编号(1 <= a,b <= n),观众a和观众b投票给了同一部电影,接下来一行是两个整数c,d(1 <= c,d <= n)。
Output
对于每一组输入,输出一行,如果观众c和观众d投票给同一部电影,输出”same”,如果不能确定,输出”not sure”。
Sample Input
5 2 1 2 2 3 1 3 5 2 1 2 3 4 1 4 5 2 1 2 3 4 2 5
Sample Output
same not sure not sure
Hint
Source
xj
AC代码(看他们的祖先是不是相同)
#include<iostream>
#include <bits/stdc++.h>
using namespace std;
int f[100000+10];
int fid(int x)
{
while(x!=f[x])
x = f[x];
return x;
}
void merg(int x, int y)
{
int xx = fid(x);
int yy = fid(y);
if(xx!=yy)
f[xx] = yy;
}
int main()
{
int n, m, i, x, y;
while(scanf("%d%d",&n, &m)!=EOF)
{
for(i = 0;i<=n;i++)
f[i] = i;
for(i = 0;i<m;i++)
{
scanf("%d %d",&x, &y);
merg(x, y);
}
scanf("%d%d",&x, &y);
x = fid(x);
y = fid(y);
if(x==y)
printf("same\n");
else
printf("not sure\n");
}
return 0;
}
电影节
Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic
Problem Description
某届电影节评选电影,共有两部电影进入最后评选环节,有n名观众,每个人有一次投票的机会,每个人都按照规则投给其中一部电影。为了了解情况,记者随机询问了一些人,一共询问了m次,特别神奇的是,记者每次都询问两个人,而且这两个人都把票投给了同一部电影,观众编号为1~n。
Input
多组输入,每组第一行是两个整数n,m (2 <= n <=100000,0 <= m < n/2),接下来m行数据,表示m次询问,每行数据有两个整数a,b代表观众的编号(1 <= a,b <= n),观众a和观众b投票给了同一部电影,接下来一行是两个整数c,d(1 <= c,d <= n)。
Output
对于每一组输入,输出一行,如果观众c和观众d投票给同一部电影,输出”same”,如果不能确定,输出”not sure”。
Sample Input
5 2 1 2 2 3 1 3 5 2 1 2 3 4 1 4 5 2 1 2 3 4 2 5
Sample Output
same not sure not sure
Hint
Source
xj
AC代码(看他们的祖先是不是相同)
#include<iostream>
#include <bits/stdc++.h>
using namespace std;
int f[100000+10];
int fid(int x)
{
while(x!=f[x])
x = f[x];
return x;
}
void merg(int x, int y)
{
int xx = fid(x);
int yy = fid(y);
if(xx!=yy)
f[xx] = yy;
}
int main()
{
int n, m, i, x, y;
while(scanf("%d%d",&n, &m)!=EOF)
{
for(i = 0;i<=n;i++)
f[i] = i;
for(i = 0;i<m;i++)
{
scanf("%d %d",&x, &y);
merg(x, y);
}
scanf("%d%d",&x, &y);
x = fid(x);
y = fid(y);
if(x==y)
printf("same\n");
else
printf("not sure\n");
}
return 0;
}